• As part of the relaunch of Skullheart, ALL previous threads have been archived. You can find them at the bottom of the forum in the Archives (2021) section. The archives are locked, so please use the new forum sections to create new discussion threads.

PS4 Fightstick Issue

Redington

New Member
Joined
Feb 22, 2016
Messages
2
Reaction score
0
Points
1
Steam
Lu Bu Pursuer
PSN
MrGongzillaz
Valentine
Hi guys, I have an issue with my fightstick (this one: http://cdn.arstechnica.net/wp-content/uploads/2009/02/originalstick.jpg) playing Skullgirls on PS4. After a certain amount of time, a message would pop up saying that controller 2 has been disconnected. At first I thought that it was the dualshock 4 turning off automatically but I removed that function and it still disconnects after some time. I haven’t calculated the exact time but it seem to be about after 10 mins or so. I tried plugging in the stick before and after launching the game but with the same result. Unplugging and plugging it back in just makes it worse, the disconnect would happen after about 10 secs. I’d really appreciate some help or some ideas.

Thanks.
 

Mike_Z

Defender of the Night
Banned
VIP
Joined
Sep 2, 2013
Messages
5,385
Reaction score
14,590
Points
113
Age
40
Location
Los Angeles, CA
Website
www.labzerogames.com
Steam
labzero_mike
PSN
MikeZWasTaken
Cerebella Big Band
Is your stick stock, or modded with firmware that includes the fake PS4 compatibility?
Because to me that sounds like the fake PS4 compatibility some firmwares have that expires after around 8 minutes because there is no Bluetooth security verification.
Does it show up in the controller select screen in-game as "Controller #" or as some crazy stick name that is not the word "Controller"? If the former, it's pretending to be a PS4 controller.
If you start the game with the stick plugged in, do you get the "A legacy controller has been plugged in - OK" screen? If not, then it is presenting itself as a PS4 controller.

Try forcing the stick into PS3 mode, look up how to do that in the manual for your board.
 

Redington

New Member
Joined
Feb 22, 2016
Messages
2
Reaction score
0
Points
1
Steam
Lu Bu Pursuer
PSN
MrGongzillaz
Valentine
So something weird just happened, I decided to try my luck again and I guess my stick works now for some reason? All I did was plug in the stick before booting up the game (which I did before but to no avail), the message of "A legacy controller..." screen popped up as Mike said, hit ok, and played for about 20 mins. Then suprise, suprise it wasn't disconnecting anymore. I don't know what happened nor what I did to make work but it works, at least for now. And just to answer Mikes questions: AFAIK the stick is not modded (bought used on ebay, didn't say that it was), the stick appears in the game as "mad catz pc usb wired controller 8838", and I don't know what you mean by "force into PS3 mode" but I can't do that anyway since it's only for PS3. Thanks for the reply though!